Ergebnis 1 bis 2 von 2

Thema: Konflikt mit 2 Plugins?!

  1. #1
    Neuer Benutzer
    Registriert seit
    27.01.2018
    Beiträge
    1

    Konflikt mit 2 Plugins?!

    Hallo an alle!

    Ich bin mit jQuery gerade mal ein paar Tage am herumwerkeln.

    Die Sprache ist mir komplett neu. Ich habe also keine Erfahrungen mit jQuery.

    Hier nun meine Frage: Wenn ich folgenden Code einfüge, und einen stippet auskommentiere funktioniert immer nur eines der Plugins. Entweder der Timepicker oder der Datepicker. Beide gleichzeitig funktionieren nicht. Hat es etwas mit den beiden jQuery-Versionen zu tun oder kann mir jemand verraten, warum das so ist?

    Es geht um folgende Codezeilen:

    Code:
            <link rel="stylesheet" href="//code.jquery.com/ui/1.12.1/themes/base/jquery-ui.css">
            <link rel="stylesheet" href="/resources/demos/style.css">
    
            <script src="https://code.jquery.com/jquery-1.12.4.js"></script>
            <script src="https://code.jquery.com/ui/1.12.1/jquery-ui.js"></script>
    
            <script>
            $(document).ready(function(){
            $( "#datepicker1" ).datepicker({ dateFormat: 'dd.mm.yy' });
            $( "#datepicker2" ).datepicker({ dateFormat: 'dd.mm.yy' });
            });
            </script>
    
    
    
    
                      <link rel="stylesheet" href="dist/css/timepicker.css">
                      <script src="https://code.jquery.com/jquery-3.2.1.slim.min.js"></script>
                      <script src="dist/js/timepicker.js"></script>
    
                    <script>
                    $(document).ready(function(){
                    $('#timepicker').timepicker();
                    $('#timepicker2').timepicker();
                    });
                    </script>
    Ich habe schon probiert, die Styles in den Header zu setzen, doch das bringt auch nichts. Es scheint, als stehen die beiden Plugins in Konflikt.

    THX
    Dave
    Geändert von jQuerydave3000 (27.01.2018 um 01:00 Uhr)

  2. #2
    Moderator
    Registriert seit
    04.05.2012
    Beiträge
    2.693
    Du solltest jQuery und jQueryUI nur maximal einmal einbinden, du brauchst dies nicht für jedes Plugin tun. Das Problem ist nämlich sonst, das du die eine jQuery Version wieder überschreibst und daher nur alles nach der reimplementierung funktioniert.
    Pakete werden jetzt mit $_DHL geliefert... nicht mehr mit $_POST

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •