Ergebnis 1 bis 5 von 5

Thema: Wordpress Max-Mega-Menu Plugin / Probleme mit jQuery Versionen

  1. #1
    Neuer Benutzer
    Registriert seit
    16.08.2017
    Beiträge
    1

    Wordpress Max-Mega-Menu Plugin / Probleme mit jQuery Versionen

    Hallo zusammen :)
    Vorab: Es geht um die Seite www.genko.de !

    Ich habe meine ersten Schritte in Wordpress gemacht und bin mit meinem Ergebnis auch zufrieden. Nur eine Sache treibt mich noch in den Wahnsinn und kann auch nach tagelanger Eigenrecherche nicht von mir gelöst werden.
    Das Menü ist ein Plugin namens "Max-Mega-Menu". Das Fly-Out Menü hat sich leider immer mit dem Content des bodys überschnitten. Darum habe ich JQuery eingebunden und folgendes Skript eingefügt:

    jQuery('.mega-menu-link').hover(function(){jQuery('#main').css('opaci ty',0.3)}, function(){jQuery('#main').css('opacity',1)});

    Das hellt den body auf, sobald ich über das Menü hovere! Echt super!
    Das Problem ist jetzt: Das Menü funktioniert in der mobilen Version nicht mehr... Es reagiert nicht.
    Sobald man jedoch die Version von jQuery auf 3.2.1 setzt, funktioniert das Menü wieder, aber mein Skript nicht mehr (aktuell wird 1.5 geladen).
    Setze ich die Version dann wieder auf 1.5, funktioniert mein Skript, aber mein mobiles Menü nicht mehr!

    Es ist also immer ein hin und her und nie funktioniert beides.

    Ich habe jetzt schon probiert:

    - ".on" mit ".delegate" ersetzt.
    - die vorgegebene Jquery Version von wordpress zu laden und jQuery manuell gar nicht einzubinden.


    JQuery wird momentan in der functions.php von mir so eingebunden:

    function my_init_method() {
    if (!is_admin()) {
    wp_deregister_script( 'jquery' );
    wp_register_script( 'jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1.5/jquery.min.js');
    wp_enqueue_script( 'jquery' );
    }
    }
    add_action('init', 'my_init_method');

    Vielleicht kann mir hier ja jemand weiterhelfen :)

    Schon mal Danke und beste Grüße,

    Martin

  2. #2
    Erfahrener Benutzer
    Registriert seit
    29.10.2014
    Beiträge
    534
    Versuche das einmal mit jQuery 3.2.1:
    PHP-Code:
    $('.mega-menu-link').hover(
      function(){ $(
    '#main').css('opacity'0.3); },
      function(){ $(
    '#main').css('opacity'1.0); }
    ); 
    i++; // zaehler i um 1 erhoehen

  3. #3
    Neuer Benutzer
    Registriert seit
    15.07.2018
    Beiträge
    2
    Zitat Zitat von freak4fun Beitrag anzeigen
    Versuche das einmal mit jQuery 3.2.1:
    PHP-Code:
    $('.mega-menu-link').hover( function(){ $('#main').css('opacity'0.3); }, function(){ $('#main').css('opacity'1.0); } ); 
    cách hack xu gunny lậu

  4. #4
    Neuer Benutzer
    Registriert seit
    15.07.2018
    Beiträge
    1
    Zitat Zitat von freak4fun Beitrag anzeigen
    Versuche das einmal mit jQuery 3.2.1:
    PHP-Code:
    $('.mega-menu-link').hover( function(){ $('#main').css('opacity'0.3); }, function(){ $('#main').css('opacity'1.0); } ); 
    gunnyh

  5. #5
    Neuer Benutzer
    Registriert seit
    20.09.2019
    Beiträge
    2

    Wordpress Max Mega Menu Plugin / Probleme mit jQuery Versionen

    Genau die Mitteilungen

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •