Ergebnis 1 bis 2 von 2

Thema: Parallax-Effekt springt

  1. #1
    Neuer Benutzer
    Registriert seit
    25.02.2014
    Beiträge
    1

    Parallax-Effekt springt

    Hallo ihr,

    ich bin recht neu hier und mir daher nicht sicher, ob ich hier im richtigen Unterforum bin...

    Mein Problem ist folgendes, ich habe diverse Parallax-Tutorials gemacht und musste mit ernüchtern feststellen, dass keines so funktioniert wie ich das gerne hätte. Also habe ich mir das selbst nach meinen Vorstellungen gebastelt, natürlich orientiert an diversen Tutorials (die Grundidee stimmt ja).

    Ich habe mehrere "Sektionen" untereinander, welche mit Hintergrund und diversen Inhalten gefüllt sind. Nun soll sich jedes einzelne Hintergrundbild dem Parallax-Effekt bedienen, was so weit auch gut funktioniert. Das Problem kommt erst dann, sobald das zweite Bild eingeblendet wird, denn genau in diesem Moment springt dieses ein paar Pixel (ca. 44.5 - habe mir die Hintergrundverschiebung des Bildes ausgeben lassen) nach unten, was ich mir überhaupt nicht erklären kann!

    Nun seit ihr an der Reihe, vielleicht findet ja jemand den Fehler.

    Den Code findet ihr unter folgender Adresse: http://alpha.pytalhost.de/default.html, ist alles in dem HTML-Dokument beinhaltet.
    Lasst euch nicht vom Design etc. abschrecken, es soll erst funktionieren und dann schön werden!

    Vielen Dank schonmal im Voraus.

  2. #2
    Neuer Benutzer
    Registriert seit
    15.07.2018
    Beiträge
    1
    Zitat Zitat von Maverick Beitrag anzeigen
    Hallo ihr, ich bin recht neu hier und mir daher nicht sicher, ob ich hier im richtigen Unterforum bin... Mein Problem ist folgendes, ich habe diverse Parallax-Tutorials gemacht und musste mit ernüchtern feststellen, dass keines so funktioniert wie ich das gerne hätte. Also habe ich mir das selbst nach meinen Vorstellungen gebastelt, natürlich orientiert an diversen Tutorials (die Grundidee stimmt ja). Ich habe mehrere "Sektionen" untereinander, welche mit Hintergrund und diversen Inhalten gefüllt sind. Nun soll sich jedes einzelne Hintergrundbild dem Parallax-Effekt bedienen, was so weit auch gut funktioniert. Das Problem kommt erst dann, sobald das zweite Bild eingeblendet wird, denn genau in diesem Moment springt dieses ein paar Pixel (ca. 44.5 - habe mir die Hintergrundverschiebung des Bildes ausgeben lassen) nach unten, was ich mir überhaupt nicht erklären kann! Nun seit ihr an der Reihe, vielleicht findet ja jemand den Fehler. Den Code findet ihr unter folgender Adresse: http://alpha.pytalhost.de/default.html, ist alles in dem HTML-Dokument beinhaltet. Lasst euch nicht vom Design etc. abschrecken, es soll erst funktionieren und dann schön werden! Vielen Dank schonmal im Voraus.
    gunny 67

Stichworte

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •